Come utilizzare la funzione TESTO di Excel? [ Spiegato con esempi]

Come utilizzare TESTO in Excel? [Con esempi]

Excel è un’applicazione potente che semplifica la manipolazione e la formattazione dei dati. La funzione TEXT è una risorsa preziosa per personalizzare testo, date e numeri secondo le preferenze individuali. Con molte possibilità di formattazione, la funzione TEXT consente agli utenti di modificare l’aspetto dei dati senza sforzo. In questo articolo esaustivo, esploreremo l’intera portata della funzione TEXT di Excel e forniremo vari esempi di formule di testo in Excel per aiutarti a padroneggiarne le capacità. Dalla formattazione di base alle manipolazioni avanzate del testo, questa guida ti fornirà le conoscenze necessarie per utilizzare la funzione TEXT in modo efficace e migliorare le tue competenze in Excel.

Formula di testo in Excel

La funzione TEXT di Excel può formattare testo, date e numeri allo stesso modo. I due input che accetta sono il valore che desideri formattare e il codice che definisce il formato desiderato. Il codice di formattazione è costituito da caratteri speciali che rappresentano diverse opzioni di formattazione.

Utilizzo di base della funzione TEXT di Excel

L’applicazione fondamentale della funzione TEXT di Excel consiste nel fornire un valore e un codice di formattazione per indicare il formato desiderato. Ad esempio, puoi utilizzare la formula seguente per visualizzare una data nella cella A1 come “gg-mmm-aaaa”, ad esempio:

=TEXT(A1, "gg-mmm-aaaa")

Questa formula di testo in Excel convertirà il valore della data nel formato desiderato. La funzione TEXT può essere combinata con altre funzioni, come CONCATENATE, per creare scenari di formattazione più complessi.

Codici di formattazione utilizzati nella funzione TEXT

I codici di formattazione utilizzati nella funzione TEXT determinano come verrà visualizzato il valore.

Alcuni codici di formattazione comuni includono:

  • “gg” indica il giorno del mese, ad esempio 1, 2 o 3.
  • “mmm” indica il nome del mese (ad esempio gen, feb, mar).
  • “aaaa” per un anno con quattro cifre (come 2023)
  • “hh” indica le ore (ad esempio 01, 02 o 03).
  • I minuti sono indicati da “mm” (00, 01 o 02).
  • “ss” indica i secondi, come 00, 01 o 02

Qui sono mostrati solo alcuni esempi di codici di formattazione. Excel offre una vasta gamma di codici di formattazione per soddisfare diverse esigenze di formattazione.

Come utilizzare la funzione TEXT in Excel?

La funzione TEXT in Excel è uno strumento potente che consente di manipolare e formattare i dati in modi personalizzati. Ecco tre casi d’uso comuni per la funzione TEXT:

Concatenare testo e numero o data in un formato personalizzato:

Utilizzando la funzione TEXT di Excel, puoi creare un formato unico combinando testo con numeri o date. Questo è utile quando si desidera presentare le informazioni in un modo particolare. Utilizza questo formato per concatenare testo con un numero o una data:

=TEXT(valore, "formato")

Ad esempio, supponiamo che la cella A1 contenga la frase “Codice prodotto:” e la cella B1 contenga il codice prodotto come valore numerico. Puoi concatenarli utilizzando la funzione TEXT nel modo mostrato di seguito:

=TEXT(B1, "Codice prodotto: ")

Questa formula di testo in Excel visualizzerà “Codice prodotto:” seguito dal valore nella cella B1.

Aggiungere zeri iniziali ai numeri

L’aggiunta di zeri iniziali ai numeri può essere fondamentale, specialmente quando si tratta di codici o numeri di identificazione che richiedono un formato specifico. La funzione TEXT consente di aggiungere zeri iniziali utilizzando un codice di formato personalizzato. Ecco il formato:

=TEXT(valore, "00000")

Ad esempio, supponiamo che tu voglia presentare una lista di numeri nella colonna A con cinque zeri iniziali. La funzione TEXT può essere utilizzata nel modo seguente:

=TEXT(A1, "00000")

Questa formula aggiungerà zeri iniziali al numero nella cella A1.

Convertire i valori in numeri di telefono in un formato specifico

Utilizzando la funzione TEXT, puoi trasformare i valori in un formato specifico di numeri di telefono. Questo è utile quando si desidera mostrare numeri di telefono con parentesi, trattini o altre scelte di formattazione, ma salvarli come numeri di base. Considera il seguente esempio fittizio:

=TESTO(valore, "(000) 000-0000")

Nella colonna A, immagina di avere un elenco di numeri di telefono che desideri formattare come “(XXX) XXX-XXXX”. Puoi fare quanto segue con la funzione TESTO:

=TESTO(A1, "(000) 000-0000")

Questa formula convertirà il numero di telefono nella cella A1 nel formato desiderato.

La funzione TESTO in Excel offre una grande flessibilità nella personalizzazione della visualizzazione dei dati. Puoi aggiungere zeri iniziali, concatenare testo e date/numeri e convertire i valori in formati specifici utilizzandola in modo efficiente. Questi sono alcuni modi in cui la funzione TESTO può essere utilizzata nella pratica. Prova a utilizzare diversi codici di formato per ottenere i risultati desiderati e migliorare l’aspetto visivo dei tuoi dati.

Esempi di funzione TESTO

La funzione TESTO in Excel offre molte possibilità per la formattazione dei dati. Esploriamo alcuni esempi comuni e casi d’uso della funzione TESTO, suddivisi in formattazione di date e orari, formattazione di numeri e manipolazione di stringhe di testo.

Formattazione di date e orari

1. Conversione dei formati delle date

La funzione TESTO viene comunemente utilizzata per convertire le date in formati diversi. Supponiamo che tu voglia visualizzare una data nella cella A1 formattata come “aaaa-mm-gg” come “gg/mm/aaaa”. Applica la seguente formula:

=TESTO(A1, "gg/mm/aaaa")

Questa formula convertirà la data nel formato desiderato.

2. Estrazione di componenti specifici (giorno, mese, anno, ecc.)

La funzione TESTO ti consente di estrarre componenti specifici da una data. Nella cella A1, immagina di avere una data da cui desideri estrarre il giorno. Puoi utilizzare la seguente formula di testo in Excel:

=TESTO(A1, "gg")

Allo stesso modo, puoi estrarre il mese utilizzando quanto segue:

=TESTO(A1, "mm")

E puoi estrarre l’anno utilizzando quanto segue:

=TESTO(A1, "aaaa")

Queste formule estrarranno i rispettivi componenti dalla data.

3. Formattazione dei valori del tempo

La funzione TESTO può essere utilizzata anche per formattare i valori del tempo. Immagina uno scenario in cui vuoi visualizzare un valore temporale nella cella A1 nel formato “hh:mm AM/PM”. Puoi applicare la formula seguente:

=TESTO(A1, "hh:mm AM/PM")

Questa formula convertirà il tempo nel formato desiderato.

Formattazione dei numeri

1. Applicazione di formati numerici personalizzati

La funzione TESTO è utile per applicare formati numerici personalizzati ai valori numerici. Supponiamo che tu voglia utilizzare il codice seguente per ottenere l’ora da una data nella cella A1. Diciamo che vuoi che la cella A1 mostri un numero con due cifre decimali. Puoi utilizzare la seguente formula:

=TESTO(A1, "0.00")

Questa formula formatta il numero con due cifre decimali.

2. Aggiunta di simboli di valuta

La funzione TESTO può visualizzare un numero con un simbolo di valuta. Supponiamo che tu voglia aggiungere il simbolo del dollaro a un numero nella cella A1 che rappresenta un valore monetario. Puoi utilizzare la seguente formula:

=TESTO(A1, "$0.00")

Questa formula aggiungerà il simbolo del dollaro al numero.

3. Visualizzazione dei separatori di decimali e migliaia

Utilizzando la funzione TESTO, puoi scegliere il numero di separatori di migliaia e decimali. Supponiamo che tu voglia che la cella A1 mostri un numero con due cifre decimali e separatori di migliaia. Puoi utilizzare la seguente formula:

=TESTO(A1, "#,##0.00")

Questa formula formatta il numero con due cifre decimali e separatori di migliaia.

Manipolazione di stringhe di testo

1. Concatenazione di testo con numeri e date

La funzione TEXT consente di unire testi, inclusi date e numeri. Immaginiamo di voler combinare un valore di testo dalla cella A1 con un numero dalla cella B1 in uno scenario ipotetico. La formula seguente può essere utilizzata:

=TESTO(B1, "0") & " " & A1

Questa formula concatenerà il numero con il testo, separati da uno spazio.

2. Estrazione di sottostringhe

La funzione TEXT può essere utilizzata per estrarre sottostringhe da una stringa di testo. La cella A1 contiene un valore di testo dal quale si desidera ottenere le prime tre lettere. È possibile utilizzare la seguente formula:

=TESTO(A1, "mmm")

Questa formula estrarre i primi tre caratteri dal testo.

3. Cambio di caso (Maiuscole, Minuscole, Iniziali maiuscole)

La funzione TEXT può anche cambiare il caso delle stringhe di testo. Supponiamo di voler rendere maiuscolo il valore di testo della cella A1. La formula seguente può essere utilizzata:

=TESTO(A1, "MAIUSCOLO")

Allo stesso modo, è possibile convertire il testo in minuscolo utilizzando:

=TESTO(A1, "MINUSCOLO")

E puoi rendere maiuscola la prima lettera di ogni parola usando:

=TESTO(A1, "INIZIALI-MAIUSCOLE")

Queste formule trasformeranno il testo di conseguenza.

Errori della funzione TEXT di Excel

Anche se la funzione TEXT di Excel è un potente strumento per formattare i dati, occasionalmente può comportarsi in modo diverso da quanto previsto. È possibile risolvere i problemi e individuare soluzioni conoscendo le cause del suo malfunzionamento. Di seguito sono riportate alcune cause tipiche del fallimento della funzione TEXT di Excel, insieme alle relative soluzioni:

Tipo di dati non valido

Perché la funzione TEXT funzioni correttamente, è necessario inserire un valore di data, intero o testo valido. La funzione potrebbe funzionare correttamente solo se il valore che si sta cercando di formattare corrisponde al tipo di dati previsto. Verifica la formattazione dei dati che stai utilizzando.

Soluzione

Verifica il tipo di dati di un valore prima di formattarlo. Utilizza le funzioni incorporate di Excel come VALORE.DATA, VALORE.NUMERO o TESTO per convertirlo, se necessario, nel tipo di dati corretto.

Codice di formato errato

Il codice di formato utilizzato nella funzione TEXT determina la formattazione desiderata. Se si inserisce un codice di formato errato o si utilizza un codice non supportato, la funzione potrebbe non produrre i risultati previsti.

Soluzione

  1. Controlla due volte il codice di formato che stai utilizzando nella funzione TEXT.
  2. Assicurati che segua la sintassi corretta e corrisponda ai requisiti di formattazione.
  3. Consulta la documentazione di Excel o le risorse online per un elenco di codici di formato validi.

Overflow di testo

Potrebbero verificarsi risultati inaspettati se il contenuto preparato è troppo lungo per adattarsi alla cella e si sposta nelle celle adiacenti. Se il testo è più largo della larghezza cellulare normale in Excel, non sarà completamente visibile.

Soluzione

Per adattare il testo preparato, allarga le colonne. Puoi regolare la larghezza della colonna manualmente facendo doppio clic sul bordo della colonna o selezionando “Adatta larghezza colonna” dal menu di formattazione in Excel.

Impostazioni regionali

La funzione TEXT di Excel si basa sulle impostazioni regionali del computer o sull’applicazione Excel. Se le impostazioni regionali non corrispondono al codice di formato utilizzato, possono verificarsi errori o formattazioni impreviste.

Soluzione

Assicurati che le impostazioni regionali in Excel corrispondano al codice di formato che stai utilizzando. Vai al “Pannello di controllo” o alle “Impostazioni” del tuo computer e regola le impostazioni regionali in modo che siano allineate al formato desiderato.

Altre funzioni di testo di Excel

Anche se Excel dispone di diverse altre funzioni di testo che possono essere utilizzate per modificare ulteriormente e trasformare il testo, la funzione TEXT è uno strumento flessibile per la formattazione dei valori di testo. Queste funzioni possono essere utilizzate insieme alla funzione TEXT per lavori di formattazione e manipolazione dei dati più complessi. Di seguito sono riportati alcuni esempi di ulteriori funzioni di testo di Excel:

SINISTRA(testo, num_caratteri)

La funzione LEFT prende una stringa di testo ed estrae un numero predefinito di caratteri dal lato sinistro (inizio). Devi fornire la stringa di testo e la quantità di caratteri che desideri rimuovere.

Esempio: =LEFT(“Ciao, Mondo!”, 5) restituirà “Ciao”.

RIGHT(testo, num_chars)

La funzione RIGHT, come LEFT, estrae un numero predefinito di caratteri dalla fine di una stringa di testo (lato destro). Sia la stringa di testo che il numero desiderato di caratteri sono necessari.

Esempio: =RIGHT(“Ciao, Mondo!”, 6) restituirà “Mondo!”.

MID(testo, start_num, num_chars)

La funzione MID prende una stringa di testo ed estrae un numero predefinito di caratteri a partire da una posizione specifica (start_num). Deve essere fornita la stringa di testo, il punto di inizio e la quantità di caratteri da estrarre.

Esempio: =MID(“Ciao, Mondo!”, 8, 5) restituirà “Mondo”.

LEN(testo)

La funzione LEN restituisce la lunghezza (numero di caratteri) di una stringa di testo. Viene spesso utilizzata per determinare la lunghezza di una stringa per ulteriori analisi o esigenze di formattazione.

Esempio: =LEN(“Ciao, Mondo!”) restituirà 13.

CONCATENATE(testo1, testo2, …)

La funzione CONCATENATE combina molte stringhe di testo in una singola stringa. Possono essere inclusi qualsiasi numero di stringhe di testo separate da virgole.

Esempio: =CONCATENATE(“Ciao”, “,”, “Mondo!”) restituirà “Ciao, Mondo!”.

UPPER(testo) and LOWER(testo)

Le funzioni UPPER e LOWER cambiano il caso di una stringa di testo da maiuscolo a minuscolo. Queste strategie sono utili quando si confrontano stringhe senza considerare la sensibilità alle maiuscole/minuscole o per uniformare le maiuscole/minuscole del testo.

Esempio: =UPPER(“Ciao, Mondo!”) restituirà “CIAO, MONDO!”.

PROPER(testo)

La funzione Proper rende maiuscola la lettera iniziale di ogni parola e trasforma in minuscolo le lettere successive. Questa funzione è ampiamente utilizzata per mantenere una capitalizzazione costante del testo.

Esempio: =PROPER(“ciao, mondo!”) restituirà “Ciao, Mondo!”.

SUBSTITUTE(testo, vecchio_testo, nuovo_testo)

La funzione SUBSTITUTE sostituisce un testo nuovo ad ogni occorrenza di un testo specificato in una stringa. L’utente deve fornire la stringa di testo originale, il testo di sostituzione desiderato (nuovo_testo) e il testo modificato (vecchio_testo).

Esempio: =SUBSTITUTE(“Ciao, Mondo!”, “Ciao”, “Ciao”) restituirà “Ciao, Mondo!”.

Conclusioni

La formula TEXT in Excel è uno strumento versatile per formattare numeri, date e valori di testo. Con la sua vasta gamma di codici di formato, gli utenti possono personalizzare l’aspetto dei dati in base a requisiti specifici. La funzione TEXT è una risorsa preziosa se è necessario formattare date e orari, manipolare stringhe di testo o applicare formati numerici personalizzati. Padroneggiando la funzione TEXT, è possibile sfruttare appieno le capacità di formattazione di Excel e migliorare la rappresentazione visiva dei dati.

Impara le basi di MS Excel con il nostro corso gratuito su Microsoft Excel: Formule e Funzioni.

Domande frequenti